libc6-dev : Breaks : libgcc-9-dev (< 9.3.0.5~) but 9.2.1-19 is to be installed

libc6-dev : Breaks : libgcc-9-dev (< 9.3.0.5~) but 9.2.1-19 is to be installed

If you have face this Error: The following packages have unmet dependencies. libc6-dev : Breaks : libgcc-9-dev (< 9.3.0.5~) but 9.2.1-19 is to be installed in kali linux While Installing python3-dev. or libc6-dev : Breaks : libgcc-8-dev (< 8.3.0.5~) but 8.2.1-19 is to be installed While Installing python3-dev. Follow the below septs to solve the error.

libc6-dev : Breaks : libgcc-9-dev (< 9.3.0.5~) but 9.2.1-19 is to be installed

Steps to Solve Error- The following packages have unmet dependencies / libgcc-9-dev install kali Linux:

(1) Install leafpad Text Editor using the command given below.

sudo apt-get install leafpad

(2) Open status file located in /var/lib/dpkg/ Folder. Open Using leafpad Text Editor.

leafpad /var/lib/dpkg/status

The following packages have unmet dependencies

Also Read: How to Change WhatsApp Status of Your Friend Without Touching his/her Phone

(3) Now Search for libgcc-9-dev word in that file and Find this Linepackage : libgcc-9-dev.

The following packages have unmet dependencies

Remove the highlighted Portion from the Line package: libgcc-9-dev  to  http://gcc.gnu.org in that File. libgcc-9-dev install kali Linux. Save & Close the File.

libgcc-9-dev install kali linux

(4) Update and Upgrade the system using the command:

apt-get update
apt-get upgrade

The following packages have unmet dependencies.

(5) To solve the E: Unmet dependencies. Try ‘ apt –fix-broken install ‘ with no packages. libgcc-9-dev install in Kali Linux.

$ apt --fix-broken install

libgcc-9-dev install kali linux

Also Read: How to enable handwrite mode in google chrome

(6) Now the last step is to update and upgrade the system. It will take 30-40 minutes to complete this process.

$ apt-get update && apt-get upgrade

libgcc-9-dev install kali linux

Now try to install python3-dev using the command sudo apt install python3-dev. Your Error: The following packages have unmet dependencies. libc6-dev : Breaks : libgcc-9-dev (< 9.3.0.5~) but 9.2.1-19 is to be installed in kali Linux or libc6-dev : Breaks : libgcc-8-dev (< 8.3.0.5~) but 8.2.1-19 is to be installed While Installing python3-dev will be solved.

If you still face any issue then comment below.

Also Read: How to Install Wifi Pumpkin 3 in Kali Linux 2020

Watch the Video:

3 comments

  1. After follow the all steps, I still get similar error. I’m trying to install g++-7 :

    sudo apt install g++-7
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    libc6-dev : Breaks: libgcc-7-dev (< 7.5.0-6~) but 7.4.0-6 is to be installed
    E: Unable to correct problems, you have held broken packages.

    Any thoughs ?

Leave a Reply

Your email address will not be published. Required fields are marked *